Morning everyone, this is my first post here.

Apologies are tendered if this has already been covered elsewhere .
Right, firstly here are my system specs:-

CPU: AMD Athlon II X4 630
Main Board: Gigabyte GA-M61PME-S2P (don't know which revision)
Memory: 4gb DDR2
Graphics card: NVIDIA GeForce GTX550 Ti 2gb

I have tried several times to install the Windows 8 Pro upgrade, initially just via the Upgrade assistant, then by creating a DVD of the ISO.

Whichever method I try, and I have tried several times, the install fails. That includes trying to keep all settings and apps, and also the keep nothing route.

On the first reboot, the screen graphics corrupt, to the point of almost not being able to read any text on the screen. The Windows logo and the 'spinning circle' are graphically broken, indeed I seem to have two examples of the circle and text alongside each other, each broken and fragmented.

I am using the latest drivers for the graphic card, but cannot find out if there are any compatibility issues with either the main board, or the Bios with Windows 8.

When the PC eventually shuts down (presumably for a restart) it just hangs there for a great many minutes. The screen goes off, yet there is some sort of activity within the PC, as the fan runs, but nothing else.

On manually restarting the PC, I get the error message about the upgrade failing, and the previous operating system is being installed (Windows 7 Home Premium).

Can anyone tell me whether my main board will accept Windows 8, or possibly provide me with links to Windows 8 compatible drivers etc for the main board and Bios?

Incidentally, how can I find out which revision of Main board I have, there are two?

Thanks in advance.

Very Best Wishes,