Windows 8 and 8.1 Forums

no signal on monitor new graphics card

  1. #1

    Posts : 1
    Windows 7 Ultimat

    no signal on monitor new graphics card

    No signal on monitor when installing new Graphics card I have just bought a new Graphics card ( Radeon HD 5450 ) to replace my old one ( Radeon x1600 series ) the problem starts when I insert my new Graphics card into my comp I get a no signal on my monitor through the graphics card or the vga slot on my comp while the new one is in place, so I cant install the drivers to set it up, yet when I take it out and re install the older card everything is fine, I have tried unisttalling my drivers for my old card and then inserting my new card to see if there was a conflict there but to no avail the same thing happens, I an running a HP pavilion a6085 computer with windows 7 ultimate on it and the mother board is a PSLP-LE, the 5450 is HDMI and the driver disc does support Win 7, can anyone advise me where to go from here as I am stuck Please. I have 4GB ram which is DDR 2 and the new card is a 1 GB DDR 3 would that make a difference,

      My System SpecsSystem Spec

  2. #2

    RAM and GPU memory can't be an issue, only compatibility issue could be with PCIe port. eventually but not too probable. If you can't see picture of BIOS, it has nothing to do with drivers (yet). Did you try resetting BIOS/CMOS ?
      My System SpecsSystem Spec

  3. #3

    Sydney, Nova Scotia, Canada
    Posts : 6,476
    Windows 10 Education 64 Bit

    To what CountMike said. If it was a driver issue it would still work in the POST/BIOS. Even if it was a driver issue, I would expect something to be displayed on screen in low resolution. It should work in standard VGA mode so you can boot into Windows and install the drivers. The video cards ram being DDR3 and your motherboard RAM DDR2 is not an issue. The Video card has its own memory controller onboard to handle its memory. Same deal for your motherboard. The two devices handle their memory independent of the other. Did you connect all the required power cables from the power supply to the video card.? It sounds like a dud card to me. If you have another PCIe slot to test it in or another PC to test it in I would.
      My System SpecsSystem Spec

no signal on monitor new graphics card

Similar Threads
Thread Forum
Installing Graphics Card No signal just black screen
Okay i have a lenovo ideacentre K330B machine type 7747 cpu G630 2.7 6gb ram integrated graphics intel hd 1000 i installed a cougar cmx 1000watt because i got a killer deal on it and i install a gigabyte radeon 7950 i have tried everything i know that i can do for this i have tried looking...
Graphic Cards
wireless signal boost to help low signal from cable tv ?
We have a nice signal from the router until about the same time each day. Only cable tv modem is available. Evidently the country neighbors do lots of internet during the afternoon. Is there a way to boost the signal coming down the cable line ? The cable tv company has installed new cables from...
Network & Sharing
Graphics card
I have the Dell Inspiron 15R 7520 SE laptop with 2GB AMD Radeon dedicated graphics. As far as I remember I have the AMD Radeon 7730 HD series hardware.Recently while upgrading my catalyst control centre I noticed that my hardware changed to AMD Radeon 7700(as seen in device manager). Can someone...
Graphic Cards
Windows 8.1 (Monitor Signal) Problem
I have a certain issue. Ever since I had updated to Windows 8.1, my monitor says "No Signal" either when I restart my computer, or turn it off. I am using a Geforce 650 TI graphics card. This issue is solved by simply booting with the default graphics card on the motherboard, and updating my...
General Support
No signal to monitor after installing new graphics card.
I have a HP Pavillion Model No. p7-1423w I replaced the stock power supply with a 600B 600W Bronze Power Supply. And installed a EVGA Geforce GTX 660 and have it powered by the new power supply. When I connect the new graphics card Via DVI-D And I got no signal. I rebooted into the BIOS to...
Graphic Cards
Clicking noise, monitor says no signal
Specs: Gpu: GTS 450 CPU: Athlon 975 3.6 BE Hdd: WD1002FAEX 1tb Ram: corsair vengeance 4x2 600w psu Windows 8.1 64b Okay so today my PC was working totally fine until I decided to finally put risers on my motherboard (also known as standoffs). I had to remove everything and put it back...
Drivers & Hardware
[DVB card Twinhan1020] Signal OK, lack of program
Welcome. I struggle with a problem already the present day. Namely, I bought a new computer: MSI b75ma-e33, Intel Pentium Processor G2030 and other components. I think the problem lies in the motherboard, but how to solve it I have no idea. Namely, after installing Windows 8 (64 bit)...
Drivers & Hardware

Eight Forums Android App Eight Forums IOS App Follow us on Facebook