Hey guys. I have ran into a huge problem. I had Windows 7 installed on my Latitude e6410 and decided to upgrade to Windows 8.1 since my university offers a free product key. I had to do the installation via USB since all I had was the key. Anyway, I followed the steps on this site for a clean install:

Reset Win 8.1 Update 1 > Win 8 Upgrade Product Key & ISO

Everything was going smoothly until after I deleted the partitions. Windows started installing but stalled after it had to reboot the first time. After the reboot, I kept receiving the error "No Boot Device Found. Press any key to reboot the machine". I rebooted the machine and went into the boot menu by pressing F12. The 'LEGACY BOOT' section had two choices: "Internal HDD (IRRT)" and "CD/DVD/CD-RW Drive". I clicked on the "Internal HDD (IRRT)" option and received "Selected boot device failed. Press any key to return to F12 menu and choose LEGACY BOOT or UEFI BOOT option". Under the UEFI BOOT option, there was a choice for "Windows Boot Manager" so I clicked it. Windows started to install again!

The problem here is that every time the system restarts now, I have to go into the boot menu and click on "Windows Boot Manager"in order for Windows to boot. Once it's booted, everything works fine. I read somewhere that my hard drive connection might be loose and to check the BIOS to see if it is recognized. My hard drive info was displayed under "Primary Hard Drive".

Does anyone have any ideas about how to fix this? It isn't a gigantic issue but it is an annoyance. Any help would be greatly appreciated!!