I am using mozilla firefox and tried to use Sky Go. Previously to yesterday, Sky Go was working fine with no problems. I understand that this error is to do with Silverlight. I have the latest version of Silverlight and are using Windows 8.1. I have tried eveything possible to fix this issue.

I have installed the 5.0 version of silverlight and ticked never update yet when trying to go to Sky Go it wont let me play the shows as it says that Silverlight needs to be installed/updated. I have changed the compatibilty of Silverlight. I have used windows 'fix it' to see if Silverlight was corrupt. I have uninstalled and installed it back again. I have ensured that the DRM box is ticked on the Silverlight application.

I really need Sky Go to work so i can watch Sky Sports on it!