Windows 8 and 8.1 Forums

Can't Delete Folder

  1. #1

    Posts : 18
    Windows 8 Professional x64

    Can't Delete Folder

    Hi guys,

    I can't delete a folder. When I try to in Explorer I get "Could not find this item. This is no longer located in..." I tried deleting the parent folder and received the same message. I tried rmdir using the command line and it says "The system cannot find the file specified."

    This isn't a special folder or anything, it was made when I un-rared something.

    I ran chkdsk /f and have no errors.

    Now here is the weird thing. I can save a text file made in Notepad to the folder, and then open it again in Notepad. But if I try to open it by double-clicking in Explorer, or try to delete it in Explorer, it fails.

    I would use a system restore but it's happening on my D: drive which is storage only, I have no backup. I can format the D: drive but it would take hours to copy over to another drive first (plus I don't think I even have the room.)

    I'd prefer not to use third-party tools to fix this but I guess I will if I have no choice.

    Please help.

      My System SpecsSystem Spec

  2. #2

    Posts : 10
    Windows 8.1 Pro

    There may be illegal and invisible characters in the directory name, or a character encoded in a way explorer cannot handle (I have even seen filenames with an asterisk * on file servers).
    It may work if you delete from the command line using wildcards as in
    rd mydir*

    If nothing helps, try to rar it with move into the archive (which will delete it from your file system when it is archived). If rar could create the file, it should know the trick to delete it.
      My System SpecsSystem Spec

  3. #3

    Posts : 18
    Windows 8 Professional x64

    Hey 5th, thanks for the idea of using WinRar. When I tried to delete it said the filename was too long, and I couldn't figure out how to add it to an archive while deleting it. Then I simply renamed it, in WinRar, and all was well, I deleted it like a normal fie. It was definitely a crazy name, or maybe didn't have a NULL terminator. I'm really happy now
      My System SpecsSystem Spec

Can't Delete Folder

Similar Threads
Thread Forum
Folder - Delete Folder Content Context Menu
Add "Delete Files in Folder" and "Empty Folder" to Context Menu of Folders in Windows This tutorial will show you how to add or remove "Delete Files in Folder" and "Empty Folder" to the context menu of folders for all users in Vista, Windows 7, and Windows 8. While you must be signed in as...
Can't delete old user name's folder
Hello, I wanted to change the initial user name I created so I followed the instruction from the tutorials here. I also made my name account as an Administrator. Now I went to C:\Users\<old_username> and tried to delete but I get this message: "you require permission from administrators...
User Accounts and Family Safety
Unable to Delete a Folder.
Hi guys, We have an older server 2003 with all sorts of account permissions on it, that also controlled the profile of this PC I'm currently sitting it. I then reinstalled Windows 8 to this PC creating a new profile independent of the server, and as a workgroup network connection. However,...
Network & Sharing
I am trying to delete a network folder in 8.1
I have a network folder called MYSHARE that I want to delete. I also have two external drives that are not recognized by the network. The two drives are Iomega(L) and Partition1 (K)/Recovery(J) 45302
Network & Sharing
Can't delete folder
I was trying to clean up my 8.1 system and encountered a folder that it won't allow me to delete or move. It is in C:\users\\appdata\local\temp and is named rarsfx4. It appears to have been used by my AV pgm., Bitdefender, at install time. When I attempt to delete it, it asks me if I want to move...
General Support
Can't delete a folder
I have a folder called C:\8e2766e5fa559c32dee2f00483e114 that contains a file called MPSigStub.exe. I can't delete it even though I've look at the 'take ownership' tutorials. Keep on getting '....require permission from IAIN-PC\Iain to make changes' error. I am Iain! Any ideas?
General Support
Delete the Windows.old folder
Hey, Pisan, if it works, let me know. I've been trying for two days to delete it. The instructions are for deleting the windows.old folder out of Windows 7, and they don't work on Windows 8. I've saved everything I want, and I can't get rid of the rest.
General Support

Eight Forums Android App Eight Forums IOS App Follow us on Facebook