Windows 8 and 8.1 Forums

Unresponsive taskbar and empty desktop after startup

  1. #1

    Unresponsive taskbar and empty desktop after startup

    After the OS boots up and I log in to my admin account, only the taskbar and empty desktop appear (attached picture). After I refresh the desktop, all of the icons appear, but everything remains unresponsive. For example, I can't minimize any windows (I can still open firefox, or file explorer though), non of the windows appear on taskbar, there are no startup processes running, the time on the taskbar is not visible, "back to desktop" in the taskbar doesn't work etc. Mouse and keyboard works, but some functions doesn't (scroll wheel)

    I tried signing in to my secondary windows account and after 15 mins the startup processes suddenly loaded and it worked when I switched to my main account as well. But then, next time I turn on the PC the same thing happens again and I can't get it working on either profile anymore. I am not sure what I did, but I suspect it was just random, because I haven't done anything significant (starting bunch of programs, ending tasks, trying to restart explorer 50 times...)

    What I tried:
    - end and restart explorer.exe
    - login to my secondary admin account, issue remains with slight variation
    - try to end different processes via task manager
    - windows 8 updates up to date

    From what I read, this could be corrupted explorer.exe or just corrupted windows profile in general?

    Anyone have any idea what could be causing this?

    Thank you.
    Attached Thumbnails Attached Thumbnails stuck.jpg  

      My System SpecsSystem Spec

  2. #2

    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit

    Open Task Manager and under processes and click explorer then End Task. Then click the File tab and Run new Process. Type explorer or explorer.exe

    If possible download and do a full scan with Malwarebytes (Free) and then do a full antivirus scan with your AV program.
      My System SpecsSystem Spec

  3. #3

    I downloaded Malwarebytes and did a scan. Everything seems to be in order.

    However, I think I found the root of the issue. I casually went through the active processes in my task manager, then I noticed one of the tasks is hogging 13% of CPU power. This process was called "Store Broker". After a quick search, it was revealed to me that this has been a common problem for a while.

    First thing I tried was to end "Store Broker" task and to my surprise, my desktop and taskbar loaded up instantly. I've done this repeatedly few times, to make sure this is where the problem lies. Other than hogging my CPU power, this process also caused my startup to be stuck in the loop. The fix for this seems fairly simple and very effective, here it is:


    Open Task Manager (CTRL + Shift + ESC) >> Go to Processes tab and then kill Store and Store Brokersprocesses:

    1. Right-Click on Store process >> End Task;
    2. Right-Click on Store Brokers >> End Task;

    Then you have to go to:
    C:\Users\(Your User Account)\AppData\Local\Packages\WinStore_xxxxxxxxxxxxx\LocalState
    xxxxxxxxxxxxx = a random string it is different to another pc;

    1. Rename folder called Cache into CacheOld.
    2. Create an empty folder with name Cache
    Why cause Store Broker (wshost.exe) high CPU usage? | How to Fix

    I will have to see how this "fix" holds up in the long-term, but so far so good.

    (Though I'll mention, that my long standing problem with a delay upon loading up startup apps (30sec) is still there, I guess thats for another thread)
      My System SpecsSystem Spec

  4. #4

    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit

    Glad you got it sorted out, keep us advised if it holds. This information may help others.
      My System SpecsSystem Spec

Unresponsive taskbar and empty desktop after startup

Similar Threads
Thread Forum
Black desktop and empty start menu, Desktop unavailable
So I rebooted my computer after a crash, and after logging in the screens were completely black and my mouse & keyboard was unresponsive. I did Crtl + Alt + Del which brought up the correct menu, and after I exited it I was put onto the start menu, which was blank. Just like the login screen and...
General Support
Can't delete empty folder on my desktop.
Yesterday I was making a bunch of videos for Youtube and my editor throws each video into a diferent folder, after that I just move all the videos into the same folder and delete the empty folder, but, for some reason, there was this one folder that would not delete, and still doesn't, it says...
General Support
How to enable taskbar toolbar at startup automatically?
I have started to use NetSpeedMonitor to monitor network speed and bandwidth usage and when it is set to start at boot, it asks to enable its toolbar on a taskbar. Obviously I would prefer, if I would not have to confirm it at every startup. I currently have it set like this and I wonder, if there...
Software and Apps
Task Manager > startup progams = Empty
Just found out that when I go to Startup items from Task manager and msconfig, Startup is not populated at all. All the items set to start are working and visible, just no listing in Startup for any. System scan including Dism comes up clean as a whistle and so is malware detection. Haven't checked...
General Support
TaskBar Buttons have become unresponsive when stacked
Hi there, I've noticed that in the past couple of weeks my taskbar buttons have become much less responsive when stacked. This is mostly in relation to internet explorer. When I have several stacked IE windows open and minimized, I sometimes have to click the taskbar button several times...
Performance & Maintenance
Desktop freezes when I empty Recycle Bin.
When I right click the Recycle Bin and click Empty Recycle Bin, the desktop freezes: the desktop become unclickable; if I click anywhere on the desktop, it just gives me a "ding" sound. Everything else works fine, like icons on the dock is clickable, I can go to start and open an app etc. ...
General Support
Folders are not empty but are shown as empty
Hello, I have an external hard and the folders in it are shown empty while they are full, but the folder inside them are shown correctly. I attached 2 images, 1045910460 Is it possible that virus cause this problem? It's actually impossible cause I have KIS2013 and it is updated. ...
General Support

Eight Forums Android App Eight Forums IOS App Follow us on Facebook