I've been having this odd problem start to crop up in the past couple of days. I don't think it happened right after I upgraded to 8.1 from 8, but it started more recently. I have isolated the problem to an issue with LogonUI.exe, and cannot find any similar descriptions via googling. I also updated my bios, reinstalled my bluetooth driver, and have the latest versions of everything available from the Lenovo website.

Normal operation works fine. The problem comes after I leave the computer for a while, and it goes to the screensaver. I have it set to display lock screen after returning, and this is where the problem occurs. The screensaver disappears, but the lock screen doesn't load properly. The background loads, but not the clock. Mouse still works and caps lock activates, but keyboard doesn't respond to any input, and the only way to get out of it is a hard power off.

Here's the event viewer log:
Faulting application name: LogonUI.exe, version: 6.3.9600.16384, time stamp: 0x5215f6c5
Faulting module name: Windows.UI.Xaml.dll, version: 6.3.9600.16408, time stamp: 0x523d4b78
Exception code: 0xc0000420
Fault offset: 0x0000000000ad7f33
Faulting process id: 0x1a30
Faulting application start time: 0x01cedaacbeafe528
Faulting application path: C:\WINDOWS\system32\LogonUI.exe
Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll
Report Id: 143b7613-46a0-11e3-beaa-6036dd57e139
Faulting package full name:
Faulting package-relative application ID:

Help would greatly be appreciated. Also, please move if this belongs in the BSOD/debugging forum: I wasn't sure. Thanks!