Windows 8 and 8.1 Forums


Problem creating Bootable USB for Lenovo UEFI Diagnostics

  1. #1



    Junior Member

    Join Date : Aug 2013
    Posts : 3
    Windows 8 Pro
    USA us illinois

    Problem creating Bootable USB for Lenovo UEFI Diagnostics


    Hi all. My Lenovo Twist (Ultrabook s230u) has ran into problems - and tries to run AutoRepair but gets hung up each time. Lenovo has instructions for creating a bootable USB to run UEFI diagnostics: Lenovo UEFI Diagnostics - Bootable USB (Create it on Windows OS) - Desktops / Notebooks / Workstations. But it doesn't work. Level 2 support (thru IBM) said they haven't found a way to run diagnostics from a USB on this model (Twist). He showed me how to disable secure boot in BIOS setup to allow both UEFI & Legacy Boot. But he also tried & failed to create a USB key from Lenovo's instructions: http://download.lenovo.com/ibmdl/pub...le-usb-204.txt. The command line given (UefiBootableGenerator.exe --create -l boot -u I -f "UEFI_Bootable_v02.00.04.zip") throws the error: "Invalid option to --create: -1". But these instructions were the same as given for a prior UEFI bootable version 1.05, which was posted in an earlier thread (www.eightforums.com/general-support/18039-how-access-boot-menu-bios-windows-8-a.html). So I thought someone here could shed some light on:
    - How to create this USB key from Lenovo's download file
    - Why the command line is not working
    - How to run the diagnostics from a USB on this Lenovo Twist

    This Lenovo model has diagnostics preloaded but, again, I've tried several times and it's not running. After starting AutoRepair, it says its running Diagnostics. Then a few times it's says checking or repairing hard drive, which says might take more than an hour. Then it either continues endlessly in waiting mode (and I found it that way after letting it try to run all night!), or else it gives message that there's a problem with your PC and we need to restart, and then it starts the process over...but never resolves.

    The unit is still within 1 year warranty and Support is sending a box for me to send it in for repair. But I'll have to see if I can access any unsaved data on the drive before sending the unit in. And before I do all that, I wanted to see if I can do what Lenovo Support said they couldn't do - create that bootable USB to run the diagnostics tool!

    Thank you!


      My System SpecsSystem Spec

  2. #2



    Member


    Join Date : Jan 2013
    Posts : 870
    Windows 8


    Quote Originally Posted by marko View Post
    The command line given (UefiBootableGenerator.exe --create -l boot -u I -f "UEFI_Bootable_v02.00.04.zip") throws the error: "Invalid option to --create: -1".
    The error message seems to be referring to "-1" but the command refers to "-l" (One being the number "1" and the other being the letter between "k" and "m" in the alphabet.) Both look very similar in that txt file of instructions, and I think they even get it wrong.
    8. Now create the USB key by entering this command:
    BootableGenerator.exe --create -l -u -f

    where
    *<-1> is the new name of the USB key (limit of 11 characters)
    (The -l and -1 look more alike in standard Courier fonts than in the Forum's font too.)

    It couldn't be as simple as confusion between 1 and l could it?

    Also, I'm assuming you checked the "I" (yet another easy confusion) later in the command was the actual letter of the USB drive or changed it?

    I guess your PC isn't working well enough to post a screenshot, but maybe a photo is possible and would be helpful?
      My System SpecsSystem Spec

  3. #3



    Junior Member

    Join Date : Aug 2013
    Posts : 3
    Windows 8 Pro
    USA us illinois


    Bingo, DavidY...you da man! In fact, the Lenovo instructions used the letter "l" and the number "1" inconsistently. It said (in Courier font):
    8. Now create the USB key by entering this command:
    BootableGenerator.exe --create -l -u -f [letter is used here]

    where
    *<-1> is the new name of the USB key (limit of 11 characters) [numeral is used here]
    *<-u> is the drive letter assigned to the USB key
    *<-f> is the name of the image

    For example:
    If the USB key has been assigned as Drive "I" by Windows, the image you downloaded is "UEFI_Bootable_v02.00.04.zip", and you name the USB key as "boot", the command would read as follows:

    UefiBootableGenerator.exe --create -l boot -u I -f "UEFI_Bootable_v02.00.04.zip" [letter is used again here]

    I had already used the correct letter for my USB drive (e.g., F instead of I). But making that one correction did the trick, and I was able to create the USB key.

    After making the necessary changes in the BIOS setup, I restarted the PC with the USB key. But the diagnostic tool doesn't seem to take over. Instead, it goes into AutoRepair mode again, then to "Diagnosing your PC", and again to "Scanning and repairing driver..." - same as before. (Lenovo Support said there was a known issue with this model, that they were unable to run the bootable diagnostic tool from a USB. So even though you helped me successfully create the USB key (which was better than the Support supervisor could do!), for some reason this laptop won't allow the diagnostic tool on the USB to take over.

    If you have any further thoughts, I'd appreciate it!
      My System SpecsSystem Spec

  4. #4



    Junior Member

    Join Date : Aug 2013
    Posts : 3
    Windows 8 Pro
    USA us illinois


    I found out another problem with the Lenovo instructions. Instead of changing the UEFI/Legacy Boot item to "Both" under Startup in the BIOS Setup, like Lenovo's instructions said, you should change it to "Legacy Only". Then the USB key worked, and I could run the diagnostics...
      My System SpecsSystem Spec

  5. #5



    Member


    Join Date : Jan 2013
    Posts : 870
    Windows 8


    Ah good news! Glad you got it to boot.

    I hope the diagnostics helped you find the underlying problem (or at least get the data off).
      My System SpecsSystem Spec

Problem creating Bootable USB for Lenovo UEFI Diagnostics
Similar Threads
Thread Forum
UEFI Bootable USB Flash Drive - Create in Windows Tutorials
Create bootable USB win8, UEFI or BIOS? Installation & Setup
Solved (Quick) question - making Windows 8 bootable in UEFI DVD Installation & Setup
Solved UEFI doesn't recognise my bootable USB device? Installation & Setup
Problem installing from WES 8 CTP 32-bit bootable IBW Installation & Setup
Eight Forums Android App Eight Forums IOS App Follow us on Facebook

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23