Windows 8 and 8.1 Forums

Windows 8 Glitching (Possible driver problem?)

  1. #1

    Strathpine, Queensland
    Posts : 179
    Windows 8 Pro 64 Bit

    Windows 8 Glitching (Possible driver problem?)

    Hey again everyone.




    After reinstalling Windows 8, it's been fine for more than a week. I installed a few programs, and the latest AMD drivers for my graphics card.

    When I rebooted, I noticed instead of booting straight into Windows 8, it showed the Samsung Logo (which it normally never does) and asked which OS I wanted to boot into, giving me an option of Windows 8 (on volume 2) or Windows 8... I deleted the "Windows 8" entry when I did a reinstall so I could install it fresh, and it's been fine until I installed the drivers.

    Then, I used my computer pretty much all night perfectly fine, played a few games... and when I tried to reboot just now, the whole computer is glitching to crap. Weirdly though, the screen capture below didn't show the glitching as bad as it is...

    Click image for larger version

    This is what my "Start Screen" looks like, and hovering over icons just makes it worse... plus everything that's Metro UI related is glitching like this, and I'm not sure whether or not it's a graphics card driver problem or what. Another weird thing I noticed, is that when I go to log in, there's no glitches, except when it says "Welcome", it flashes black for like a millisecond then continues to log in...

    Click image for larger version

    Above is now my desktop. The resolution is screwed up, even though it's apparently already on 1366x768 as it is meant to be. Also, yes, that EXTREMELY glitched up thing on the right and partially on the left near the bottom is my "Charm Bar". It's that badly messed up, the only way I could navigate was off pure recognition of the item locations.

    I've never come across a problem as such before, and I think it may have something to do with the new graphics card drivers. Below are my system specs:

    Operating System: Windows 8 Pro 64-bit (6.2, Build 9200) (9200.win8_gdr.121119-1606)
    System Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
    System Model: 355V4C/355V4X/355V5C/355V5X/356V4C/356V4X/356V5C/356V5X/3445VC/3
    BIOS: BIOS_VENDOR Ver: P02AAN.014.120607
    Processor: AMD A6-4400M APU with Radeon(tm) HD Graphics (2 CPUs), ~2.7GHz
    Memory: 4096MB RAM

    Graphics and GPU information:

    Card name: AMD Radeon HD 7600M + 7600M Dual Graphics
    Manufacturer: Advanced Micro Devices, Inc.
    Chip type: AMD Radeon HD 7520G (0x9990)

    Now, the following I would dare say has changed after I installed the drivers:

    Driver Model: WDDM 1.2

    If anyone knows how to revert back to old drivers or fix this problem, it would be greatly appreciated. I would also like for this thread to be moved to the appropriate forum if needed.

    Last edited by CeejayMode; 04 Jan 2013 at 19:40.

      My System SpecsSystem Spec

  2. #2

    I would either reload the older video drivers or see if you can revert the system to a state before you installed the new video drivers (driver roll back, or something like that). If I was at my win8 PC I could give you better instructions... Good luck!
      My System SpecsSystem Spec

  3. #3

    Strathpine, Queensland
    Posts : 179
    Windows 8 Pro 64 Bit

    Quote Originally Posted by azasadny View Post
    I would either reload the older video drivers or see if you can revert the system to a state before you installed the new video drivers (driver roll back, or something like that). If I was at my win8 PC I could give you better instructions... Good luck!
    Thanks man, I'll give it a go today. I was using my laptop earlier and I noticed if I access the Metro UI apps in other ways, they work fine without glitching, so now it's just the charm bar and start screen messing up. But yeah, I'll reinstall old drivers, thanks.
      My System SpecsSystem Spec

  4. #4

    Strathpine, Queensland
    Posts : 179
    Windows 8 Pro 64 Bit

    Everyone, the problem seemed to somehow fix itself. It's really weird how it just did it, then again, it's Windows 8.
      My System SpecsSystem Spec

  5. #5

    Sounds like a flakey driver, it's common...
      My System SpecsSystem Spec

Windows 8 Glitching (Possible driver problem?)

Similar Threads
Thread Forum
anyone else with nvidia driver problem windows 8.1?
I recently got an GeForce GTX 650 Ti BOOST card a couple weeks back. I think right after I upgraded from windows 8 64-bit to windows 8.1 64-bit. it was running well for awhile. But after some updates, now videos will stutter badly even after reboot. After updating to the latest driver, I've...
Graphic Cards
Missing or glitching System Icons on 8.1
Hello All, I seem to be having an issue with the System UI on Windows 8.1. This is a fresh installation with only a few extras installed. Some select system UI icons have been replaced with rectangles, and is getting to be quite a nuisance. The photos point out only a few of them that show up...
General Support
Windows 8.1 Fresh install Driver??? problem
Just completed the 8.1 upgrade. and my Lenovo Laptop z570 will not stop beeping... I did notice that in my device drivers, under OTHER Devices. I have an unknown Device. on Microsoft ACPI-Compliant Embedded This was never an issue before.. I've removed EVERY USB Device i have and still the...
Windows Updates & Activation
Windows 8 Driver Installation problem
Operating Sistem Windows 8 Pro x64 Motherboard Asus M5A97 Hello , I've been scouting the internet a lot for answers ; unfortunately found none for Windows 8.Trust me , I really searched and tried solutions , but didn't work.This is the message I'm getting for EVERY new driver I try...
Drivers & Hardware
Google Chrome Glitching out in Windows 8 Mode
Hi, I use Google Chrome as my default browser but every time i launch chrome in Windows 8 mode, it starts glitching up. Google Chrome is set as me default browser. 1. Chrome has no metro icon: 19582 2. When i click Chrome it launches the desktop then Metro Chrome. 3. Metro Chrome has no...
Browsers & Mail
Glitching screen/multiple images (Video)
A little while ago I started to notice glitching on the screen of little divs flashing about on my browser. I just ignored it and now it is gone haywire. This is what it does. I also don't have Windows 7 installed. It was a custom build and I wasn't really thinking when it came to the OS so I...
Graphic Cards
Windows 8 installation driver problem
I'm trying to install windows 8, but on the beginning i'm getting error like: "Brak wymaganego przez system nośnika sterowników" which simply means missing driver. About the description - it's about missing cd/dvd or disk driver. Still, when it makes me to found them, i have access both to my...
Installation & Setup

Eight Forums Android App Eight Forums IOS App Follow us on Facebook