Windows 8 and 8.1 Forums


Red Faction Guerilla crash

  1. #1

    Red Faction Guerilla crash


    Every time I try to play red faction guerrilla it just simply crashes with a visual c++ runtime error... (non specific)
    The recommended settings are xp sp3 compatibility mode, which just doesn't launch...

    Any thoughts, ideas, or suggestions?

      My System SpecsSystem Spec

  2. #2


    Interestingly enough, a modified version of the launcher (illegitimate) allows me to play the game (this then cancels the ability to sign into GFWL though, as the modified file is not meant to use the feature...)
      My System SpecsSystem Spec

  3. #3


    *sigh* and now I have all sorts of flickering despite being in xp sp 3 mode...
      My System SpecsSystem Spec


  4. #4


    127.0.0.1
    Posts : 144
    Windows 8.1 Pro x64


    Are you using the x86, or x64 version of Windows 8? Also, your system specs are not complete. That would help us a lot if you could fill those in.
      My System SpecsSystem Spec

  5. #5


    My specs aren't complete because I am having issues with 2 different computers.
    The RF:G comp is as follows:
    Windows 8 CP 32-bit
    Amd Athlon II 240 2.80GHz x2
    Nvidia Geforce GT 520 2GB
    3.5 GB DDR2 Ram
    750GB Hdd WD Scorpio Blue
    Asus M4N78 Pro Motherboard
    Last edited by RolandHazoto; 13 Mar 2012 at 14:36. Reason: Updated my gfx card
      My System SpecsSystem Spec

  6. #6


    127.0.0.1
    Posts : 144
    Windows 8.1 Pro x64


    Visual C++ runtime error? Try installing this:
    http://www.microsoft.com/download/en...s.aspx?id=5555
      My System SpecsSystem Spec

  7. #7


    Quote Originally Posted by RolandHazoto View Post
    Well I uninstalled every C++ redistributable and reinstalled 2010,2008,2005 and express (in that order) and I still get the error.
    I then ran sfc /scannow just for giggles...
    Not a thing as changed.
    I'm also receiving a runtime error with a game but that one does not provide me a specific error code (thread posted in gaming forum)
    I'm perplexed.
    A friend of mine does not receive this error, and a laptop I had 8 installed on briefly did not recieve this error either, so it seems especially anomalous...

    Tried that while trying to fix another issue...
      My System SpecsSystem Spec

  8. #8


    Interesting development! I had the same issue with a version of Monday Night Combat I was "trying out" before I buy it and to fix it I just had to delete a specific .ini file....
    Course RF:G doesn't have much in terms of inis but it does seem to imply some kind of bad configuration somewhere...
    Tried deleting my options from my documents but that did nothing...
      My System SpecsSystem Spec

  9. #9


    I am having same C++ error and even tried the fix. Problem still happens
      My System SpecsSystem Spec

Red Faction Guerilla crash

Similar Threads
Thread Forum
Any 3D game will crash
Hello, any game that uses any sort of 3D rendering will always crash on my computer. It will run fine, I can set the graphics high, but it will always crash. Looking for something to start working on improving this. I'm using an Nvidia Geforce 770 with the latest drivers installed.
Gaming
Windows 8 Pro crash
Hi, i'm newbie and not good in English. If there is anyone help to solve my problem, i'm really appreciate. My PC is 3 years old, Q9950 - Asus x48 -Dual 2x2G 800Mhz- 160G Samsung and I has installed Win 8 Pro for 6 month Recently, it's just random restart one (or two) time each few day(3-4)....
BSOD Crashes and Debugging
De-bugging/crash
I have been having some crashes as of late. My screen goes red, and then the computer resets. I am thinking that it may possibly be memory related. Any feedback/ Input would be helpful.
BSOD Crashes and Debugging
Win 8 Crash
I think I mentioned this a long time ago, but cannot find thread. I have just had a Win 8 crash on my pc. 'Your pc encountered a problem' and 'kernel security' is mentioned but no error number. After rebooting itself it asks me to wend problem report to Mickeysoft which I did. It does not occur...
General Support
BSOD and total windows crash and recovery crash/failure
Hey, My month and half old Acer V3 started to give BSOD's, did some sort of recovery and started working again for a couple of hours, if not trying to access any Windows files. If tried to look up error logs etc it gave different versions of the BSOF. So I tried to run Recovery, getting it back...
BSOD Crashes and Debugging
explorer crash
can any one tell me what app is causing the explorer to crash? I did not see any crash report..I saw this in the reliability report? 10952
General Support
Crash on wake
Attached minidump files. Thanks in advance!
BSOD Crashes and Debugging

Eight Forums Android App Eight Forums IOS App Follow us on Facebook