Windows 8 and 8.1 Forums


Windows 8 with age of empires?

Page 1 of 3 123 LastLast
  1. #1



    Junior Member

    Join Date : Sep 2011
    Posts : 3
    Windows 8

    Windows 8 with age of empires?


    i wish to play age of empires on it but it just opens any ideas?
    also i tried changing compatability it didnt fix anything


      My System SpecsSystem Spec

  2. #2



    Closed by Request

    Join Date : Sep 2011
    Posts : 162
    Windows 8 Developer Preview x64


    Which AoE are you trying to play? I'm playing AoE3 without problems on Windows 8 DP 8102 with no compatibility mode set.
      My System SpecsSystem Spec

  3. #3



    Junior Member

    Join Date : Sep 2011
    Posts : 3
    Windows 8


    Aoe3 yes its the one i bought and it does not work :/
      My System SpecsSystem Spec

  4. #4



    Junior Member

    Join Date : Sep 2011
    Posts : 3
    Windows 8

    Windows 8 With age of empires 3?


    It does not seem to work for me on windows 8
    when i open it it seems to crash or somthing
    i tried changing it to run in windows 7 mode but that didnt work
    any help?
      My System SpecsSystem Spec

  5. #5



    Closed by Request

    Join Date : Sep 2011
    Posts : 162
    Windows 8 Developer Preview x64


    Quote Originally Posted by Kytopia View Post
    It does not seem to work for me on windows 8
    when i open it it seems to crash or somthing
    i tried changing it to run in windows 7 mode but that didnt work
    any help?
    Are you talking about the compatibility warning it gives you? If so, just ignore it and run anyway.

    If it's an error, could you please post a screenshot of the error? It may help people to help you.
    Last edited by synaptix; 21 Sep 2011 at 11:32 AM.
      My System SpecsSystem Spec

  6. #6



    Member

    Join Date : Mar 2012
    Calgary, AB
    Posts : 10
    Windows 7, Windows 8 Consumer Preview
    Canada ca alberta


    Does AoE 1 work? Me and my friend play multiplayer on that one when he's here
      My System SpecsSystem Spec

  7. #7
    vrosa's Avatar

    Senior Member


    Join Date : Jan 2011
    Belo Horizonte
    Posts : 4,165
    Windows 10 Tech Preview
    Brazil


    I wouldnt bet, in AOE 2 the colors of objects change, the water was dark, and the field yellowish
      My System SpecsSystem Spec

  8. #8
    Hopachi's Avatar

    Polyhedric Stellation


    Join Date : Sep 2011
    Orbiting the Moon
    Posts : 2,928
    Windows 8.1 - 64bit, Others in VMs
    european union


    AOE 2 in Windows 7 x64 has bad colors: pink water and stuff.

    I tried it in DP x86 and the colors were good ingame works good, only the menu's were bad . Maybe it's an issue on Win7 and Windows 8 x64 editions?

    I'll try it in CP x64 but as vrosa said it's not looking too good for now for AOE 2 (or lower).
      My System SpecsSystem Spec

  9. #9



    New Member

    Join Date : Mar 2012
    Posts : 1
    Windows 8 x86 CP Build 8250


    i have the same problem, its not showing any errors, im even runnign in compat mode. the only thing that happens when i try to play is. "Protection Stub" in task manager starts using up about 3/4 of my system resources for about 5 - 7 minutes then the splash for the game will come up, Windows changes the display res and then AOE process terminates or freezes.


    2GB RAM - Only Using about 500mb with just windows running

    AMD Athlon Dual Core QL-62 2.0ghz

    On a lappy with nVidia GeForce 8200m
      My System SpecsSystem Spec

  10. #10
    Hopachi's Avatar

    Polyhedric Stellation


    Join Date : Sep 2011
    Orbiting the Moon
    Posts : 2,928
    Windows 8.1 - 64bit, Others in VMs
    european union


    Hi there,

    Some time ago I tested AOE2 in Dev Preview x86 and it works well ingame (worked even in Virtualbox with good colors).

    I tested AOE2 in Windows 8 CP x64 in VMware Player. I can say that it works just as well as in x86.
    The menu's are changed in color (as always) but it works well ingame.

    To begin this is a screenshot of AOE2 match in Win7 x64 SP1:
    Click image for larger version
    That's the pink water I've been complaining about + the rest is also bad-looking.
    The screenshot (printscreen) looks worse than what you normally see when you play. There are with no doubt issues (graphics is old with 16bit color or lower). => Surprisingly when you enter the game: The menu looks OK.

    Now this is the menu in Windows 8 CP x64:
    Click image for larger version
    The colors are diffrent than normal.

    Now for ingame:
    general:
    Click image for larger version
    looks good

    Trees:
    Click image for larger version
    good, as expected

    But most importantly water:
    Click image for larger version
    very good (looks normal) (compared with the mess from win7)

    lake:
    Click image for larger version

    The game in x64 couldn't start. The fix was to add extra registry settings to Wow6432Node:
    Click image for larger version

    The game works well in Windows 8 x64.
    Age of Empires 2 (v.2.0a) works well without compatibility settings (only the registry fix needs to be applied if not working well without).
    So for me it can be added to the list of working games in the well known thread here on the forum.

    That's it

    Hopachi
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Windows 8 with age of empires?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23