Windows 8 and 8.1 Forums

Show Us Your Rig!

  1. #651


    Bay Area
    Posts : 21,382
    Windows 7 Home Premium x64


    Quote Originally Posted by MrShowdown View Post

    It finally gave up lol. Currently looking for a sub $40 quality PSU.
    Those words don't often go together

    EVGA 100-W1-500-KR 500W ATX12V / EPS12V 80 PLUS Certified Active PFC 3 Year Warranty Power Supply Intel 4th Gen CPU Ready - Newegg.com

    A Guy

      My System SpecsSystem Spec

  2. #652


    Quote Originally Posted by A Guy View Post
    Quote Originally Posted by MrShowdown View Post

    It finally gave up lol. Currently looking for a sub $40 quality PSU.
    Those words don't often go together

    EVGA 100-W1-500-KR 500W ATX12V / EPS12V 80 PLUS Certified Active PFC 3 Year Warranty Power Supply Intel 4th Gen CPU Ready - Newegg.com

    A Guy
    Nah, me and my dad managed to find a Corsair VS450 for $39. Too lucky.
      My System SpecsSystem Spec

  3. #653


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional
      My System SpecsSystem Spec


  4. #654


    Bay Area
    Posts : 21,382
    Windows 7 Home Premium x64




    A Guy
      My System SpecsSystem Spec

  5. #655


    It never ends Durahl,does it?Shed some light in there...
      My System SpecsSystem Spec

  6. #656


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional


    The new build wasn't exactly planned or at least not at that time so everything was a little bit rushed -__-

    Basically I had a leakage onto the first PCIe Slot that toasted the GPU and that particular area of the Motherboard.
    The leakage occurred in a rotary fitting which I was probably caused by the flexing of the case during movement.

    I'm still having some issues with the Motherboard as something is conflicting with the Fast Boot Option when the SATA Drives are connected.
    Not that it would matter as I'm rarely making a Cold Boot ( 98% of the time I'm using Sleep ) but I'd still prefer for it to work just for the sake of it.

    I also had some issues with the Sound Card being installed in the 2nd PCIe 16x Slot.
    Now that I put it into the PCIe 4x Slot it appears to be working fine as it's now being recognized after returning from Sleep.

    System Specs:
    OS: Microsoft Windows 8.1 Professional
    Case: Corsair 900D
    CPU: Intel Core i7-5930K
    Motherboard: ASUS RAMPAGE V Extreme
    Graphics Cards: 2x EVGA GTX 980 SC
    Memory: 32GB DDR4 Corsair Dominator Platinum
    Sound Card: Creative Sound Blaster ZxR
    PSU: Corsair AX1200i Digital ATX Power Supply
    SSD Drive:
    1x Kingston HyperX Predator 480GB M.2
    HDD Drives: 4x Western Digital Caviar Green 1TB
    Cooling: EKWB / Aquacomputer Custom Water Cooling

    Monitor(s):
    Displays 3x Dell UltraSharp U3011 / 1x Wacom Cintiq 24HD Touch
    Screen Resolution: 3x 2560x1600 / 1x 1920x1200
    Keyboard: 2x Logitech G710+ Mechanical Gaming Keyboard / 1x Logitech G13 Advanced Gameboard
    Mouse: Logitech G700 Wireless Gaming Mouse / 3DConnexion Space Pilot PRO
    Joystick: Saitek X-65F Combat Control System
      My System SpecsSystem Spec

  7. #657


    Posts : 143
    Windows 8.1


    This is mine;
    Click image for larger version

    Click image for larger version

    Click image for larger version
      My System SpecsSystem Spec

  8. #658


    Posts : 143
    Windows 8.1


    On the above rig, I do not play any games, it is just a place where I hang out and surf the interweb and listen to music and stuff.
      My System SpecsSystem Spec

  9. #659


    Wolves, England
    Posts : 143
    Win7 Pro x64 | Win8.1 Pro x64 VM | Win 10TP x64


    A fair few upgrades lately including a new i7-4790k have taken my rig from this

    Click image for larger version

    Click image for larger version

    To this

    Click image for larger version

    Click image for larger version

    Still need to do some cable management but I'll get round to it.
      My System SpecsSystem Spec

  10. #660


    Excellent component's choice,a processor that benchmarks ,figures like that,is indeed considered an...upgrade!How about temperatures,how 'hot" is that 980 getting?

    Them red SATA's? Cut'em...
      My System SpecsSystem Spec

Page 66 of 67 FirstFirst ... 165664656667 LastLast
Show Us Your Rig!

Similar Threads
Thread Forum
Show us your WEI
My WEI score is better in 8 than in seven... How to Update or Refresh the Windows Experience Index (WEI) Score in Windows 8 and 8.1 32 bit developer preview w/2 Gb ram in VMware workstation 8 1986
Performance & Maintenance
Why so many new members do not show their rig
Strange thing and not my concern.... but recenly many questions for help are asked while computer info is NEVER shown. Jeff
General Support
second HD does not show in win explorer
Hi, 1. I backed up my Seagate win8 "C" partition, using Paragon, in the spare Maxtor HD & it used 61.9GB, the rest 50gb are free space. As Win8 was installed in "C" I presumed that The Maxtor if installed alone in the PC it would boot up but, it does not. Should't it? 2. The other thing is...
Drivers & Hardware
video won't show
I appreciate your help. When I go to NEWS then I click on the picture with VIDEO, all I can see is a dark screen with an arrow on left top screen indicating going back. Could you please tell me what's wrong with my computer or OS. Why it doesn't show the video. Thanks.
General Support
no show image
When I click the photo image is not displayed While the small mode is displayed. 26637 26638 why?
General Support
External do not show up
Hi, I have this problem were external hard drive do not show up on my PC. First my I put my friends in and it did not work, then I went out and brought one myself (different brand) and it does not show up. Windows automatically installed the drivers it said it even know what time of external...
Drivers & Hardware
show us your BBC apps
if you are lucky enough to find them show us your favs... heres mine 22297
Chillout Room

Eight Forums Android App Eight Forums IOS App Follow us on Facebook