Windows 8 and 8.1 Forums

Show Us Your Rig!

  1. #351

    RIG!


    That must have taken you a lot of hard interesting hours!

    I know that when I build (Very Simple Ones, the Last one about a month ago) I really have to apply attention to what I am doing.

    How long did it take you to assemble this before hitting the "Launch Button"!

    It is always a traumatic time for me!

    Well Done!

    Tully

    The Old Fart

      My System SpecsSystem Spec

  2. #352


    Great case,killah components,amazing result.Congrats on that one,here sir,take my like!
      My System SpecsSystem Spec

  3. #353


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional


    Quote Originally Posted by Tully View Post
    How long did it take you to assemble this before hitting the "Launch Button"!
    Building a entirely new PC usually takes me about 2 days with about 1 day usually being accounted for getting hardware conflicts sorted out and the software back running.

    The combined time it took for THIS particular system though was probably a week, stretched over a longer period, because of all the sleeving I've had to do which was a first for me - About half of the cables are from a spool, the other half being shortened cables that came with the PSU.

    Cable management ( if I'm actually allowed to call it like that ) was a huge pain as the Case doesn't feature any possibilities to route cables in the back and the angled 24pin of the Motherboard sure did it's best in becoming a huge pain when combined with the rather stiff sleeving of the cables.

    Quote Originally Posted by proudtobegreek View Post
    Great case,killah components,amazing result.Congrats on that one,here sir,take my like!
    Thanks a lot :)
      My System SpecsSystem Spec


  4. #354


    Bay Area
    Posts : 21,384
    Windows 7 Home Premium x64


    Beautiful rig Durahl

    A Guy
      My System SpecsSystem Spec

  5. #355


    Posts : 272
    windows 7


    Wow Durahl! I am in love with your setup, you have a Cintiq 24 too... it's my dream to own one of those babies :-)
      My System SpecsSystem Spec

  6. #356


    Very nice, Durahl.
      My System SpecsSystem Spec

  7. #357


    Posts : 272
    windows 7


    Thanks to Durahl I suddenly feel inadequate.... it's like being back in the locker rooms again! lol
      My System SpecsSystem Spec

  8. #358


    Nearby... In an astronomical sense.
    Posts : 43
    Microsoft Windows 10 Professional


    Thanks everyone!
    Click image for larger version
      My System SpecsSystem Spec

  9. #359

    My latest updates...


    I just added a 2nd GTX-660 SC video card in SLI for the heck of it. These are the latest pics from last Friday's maintenance work. It's running great!
    Attached Thumbnails Attached Thumbnails WP_20140209_005.jpg   WP_20140209_006.jpg   WP_20140209_002.jpg  
      My System SpecsSystem Spec

  10. #360


    Clean,minimal,powerful build!Zip tie them extra 2pins,sleeve 'em,whatever and be done!
    Any fps improvements,higher settings achieved,do you even game?
      My System SpecsSystem Spec

Page 36 of 67 FirstFirst ... 26343536373846 ... LastLast
Show Us Your Rig!

Similar Threads
Thread Forum
Show us your WEI
My WEI score is better in 8 than in seven... How to Update or Refresh the Windows Experience Index (WEI) Score in Windows 8 and 8.1 32 bit developer preview w/2 Gb ram in VMware workstation 8 1986
Performance & Maintenance
Why so many new members do not show their rig
Strange thing and not my concern.... but recenly many questions for help are asked while computer info is NEVER shown. Jeff
General Support
second HD does not show in win explorer
Hi, 1. I backed up my Seagate win8 "C" partition, using Paragon, in the spare Maxtor HD & it used 61.9GB, the rest 50gb are free space. As Win8 was installed in "C" I presumed that The Maxtor if installed alone in the PC it would boot up but, it does not. Should't it? 2. The other thing is...
Drivers & Hardware
video won't show
I appreciate your help. When I go to NEWS then I click on the picture with VIDEO, all I can see is a dark screen with an arrow on left top screen indicating going back. Could you please tell me what's wrong with my computer or OS. Why it doesn't show the video. Thanks.
General Support
no show image
When I click the photo image is not displayed While the small mode is displayed. 26637 26638 why?
General Support
External do not show up
Hi, I have this problem were external hard drive do not show up on my PC. First my I put my friends in and it did not work, then I went out and brought one myself (different brand) and it does not show up. Windows automatically installed the drivers it said it even know what time of external...
Drivers & Hardware
show us your BBC apps
if you are lucky enough to find them show us your favs... heres mine 22297
Chillout Room

Eight Forums Android App Eight Forums IOS App Follow us on Facebook