For the past few weeks, I've been noticing my icons keeps refreshing or rebuilding itself without touching the icon cache database. Paranoid because I had my first disk crash last year and didn't back up my files, I ran a few tests on this hard drive to see if there is something wrong.

This is the HD Tune results:
Click image for larger version

I posted a thread about the results above and it seems like everything is all good.
After around a week, I tested my HDD again because the icon rebuilding itself every single time is just driving me nuts. I don't know if it's the HDD or something else entirely that's causing this.

The HD tune results were quite surprising (this was run in safe mode, the results is the same in normal mode):
Click image for larger version

I got worried now, so I ran another test (still on safe mode):
Click image for larger version

The result above is slightly different than the first result. It seems the lines are more rougher. The second result is a mystery to me, I don't know why it made so many low dips around the middle even though it's in safe mode.

I was wondering if is it time for a new hard drive? I'm thinking about buying an SSD. Also, this computer was bought around 4 months ago and this computer is RMA'ed. The first computer I got had a fan problem, and I RMA'ed it and got this new one without any charge.
If I may add, there are no sounds coming from the hard drive. If I put my ears really close to the hard drive, I only hear clicking sounds (not "Click of death" sounds) that sounds like the hard disk is parking. Even in a quiet environment, you can't really hear anything from the HDD unless you put your ear right next to it.

Thank you in advance.