Windows 8 and 8.1 Forums


WD Passport Ultra not recognized - at all!

  1. #1



    Junior Member

    Join Date : Jan 2013
    Posts : 10
    Windows 7, 8.0, 8.1

    WD Passport Ultra not recognized - at all!


    Hi all,

    In the process of installing a new Win 8.1 machine, going mostly OK, but I have a WD Passport Ultra that is not working with it at all. I plug it in, it lights up and spins, but never shows up as a drive either in "This PC" or in disk management; nothing at all in device manager either. I would have said defective unit, but it works perfectly on all my other installs including Vista, 7, 8.0 and even a Mac! Don't know what to do here, I can certainly access the files on another machine and transfer, but I would like to use this drive with the new machine...

    Any ideas?

    Thanks, --ch


      My System SpecsSystem Spec

  2. #2



    VIP Member


    Join Date : Jun 2010
    USA
    Posts : 550
    Windows 8.1 Pro with Media Center
    USA us virginia


    For some odd reason between Window 8 and WD's Passport drives, they tend to somehow mysteriously drop their drive letters. I've had this happen to me on an older (less than a year drive) and a brand new one I got for Christmas.

    Anyway go into Disk Management and check to see that the drive is showing and it has a drive letter. It it's showing but has no drive letter, assign one and your issue should be resolved.

    If the drive isn't showing, make sure your cables are good, and not too long as this will also cause the drive not to show up.

    Good luck.
      My System SpecsSystem Spec

  3. #3



    Junior Member

    Join Date : Jan 2013
    Posts : 10
    Windows 7, 8.0, 8.1


    Unfortunately, the drive isn't showing at all... The cable is the original (very short) cable provided with the disk. It all works on all my other machines including one with Win 8.0...

    In the taskbar notification area, I get a constant flicker of the "safely remove" icon when the drive is plugged in, as if it's trying to do something but not succeeding... Even in Disk management I see a quick flicker of the scroll bar, like it tries to connect and fails...

    --ch
      My System SpecsSystem Spec

  4. #4



    VIP Member


    Join Date : Jun 2010
    USA
    Posts : 550
    Windows 8.1 Pro with Media Center
    USA us virginia


    Then try different ports and/or different cables. And if you have another PC try the drive there; It could be the drive itself that's bad.
      My System SpecsSystem Spec

  5. #5



    Junior Member

    Join Date : Jan 2013
    Posts : 10
    Windows 7, 8.0, 8.1


    Quote Originally Posted by sygnus21 View Post
    Then try different ports and/or different cables. And if you have another PC try the drive there; It could be the drive itself that's bad.
    as I mentioned in my previous posts:

    It all works on all my other machines including one with Win 8.0...
    (I do not have another machine with Win 8.1)

    I also tried all the other ports, front and back, on the machine in question - first thing I did - same symptoms... Anything else plugged into those ports work fine, including mice, keyboards, usb sticks, etc...

    --ch
      My System SpecsSystem Spec

  6. #6



    VIP Member


    Join Date : Jun 2010
    USA
    Posts : 550
    Windows 8.1 Pro with Media Center
    USA us virginia


    Well other than suggesting you may have a bad drive, I'm out of suggestions.

    Good luck.
      My System SpecsSystem Spec

  7. #7



    Member

    Join Date : Nov 2013
    Posts : 22
    Windows 8.1


    If your Ultra is USB 3.0, and you have a USB 2.0 port available on the PC, try plugging it in to the USB 2.0 port to see if a drive letter is assigned. If not, check Disk Management to see if it is recognized.......after that, I don't have any further suggestions.........

    Good luck and Happy New Year!
      My System SpecsSystem Spec

  8. #8



    VIP Member


    Join Date : Jun 2010
    USA
    Posts : 550
    Windows 8.1 Pro with Media Center
    USA us virginia


    Quote Originally Posted by fallen View Post
    If your Ultra is USB 3.0, and you have a USB 2.0 port available on the PC, try plugging it in to the USB 2.0 port to see if a drive letter is assigned. If not, check Disk Management to see if it is recognized.......after that, I don't have any further suggestions.........

    Good luck and Happy New Year!
    Already suggested....

    Quote Originally Posted by sygnus21 View Post
    Anyway go into Disk Management and check to see that the drive is showing and it has a drive letter. It it's showing but has no drive letter, assign one and your issue should be resolved.

    If the drive isn't showing, make sure your cables are good, and not too long as this will also cause the drive not to show up.

    Good luck.
    Also suggested trying different ports - post #4
      My System SpecsSystem Spec

WD Passport Ultra not recognized - at all!
Similar Threads
Thread Forum
Window 8.1 on Samsung Series 7 Ultra General Support
Solved New WD 1TB Passport error. Drivers & Hardware
Windows 7 Dual boot on Acer S3-391 Ultra Book Installation & Setup
Can't start Windows 8 on Samsung Series 5 Ultra General Support
Solved Fix file system on external WD passport? Drivers & Hardware
Eight Forums Android App Eight Forums IOS App Follow us on Facebook

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23