Windows 8 and 8.1 Forums

How to get BT working on Win8.1 + Dell XPS 1340?

  1. #21

    Posts : 33
    Win 8.1 Pro x64

    Hi Orlando,

    Yes, I guess that is likely I messed something up something playing around with all the drivers to get Wifi/BT working. I guess I will just do one more clean install. It would be like 105th one :-D

    Nvidia drivers - I simply went to their website and let the site automatically detect my GPU. The I downloaded the suggested driver. Currently it is 331.58 (WHQL), released yesterday October 21. I just downloaded and installed it this morning. But this driver is only installed for GeForce 9400M G (integrated graphic card), not for GeForce G210M. Not sure if you have the same configuration. For the second one it suggests to go to manufacturer's website for the drivers.

    Click image for larger version

    When I select GeForce 200M series on Nvidia website it offers this same driver I already have for GeForce 9400M G. But it just does not install for the 210M card. I guess it's just because INF file.

    And there is another thing with graphics. I cannot switch those, 9400M G is selected as primary without any way to change it. in Windows 7 I had this small SLI icon in tray where I could select which one I want to use. Are you able to switch graphic card?

    So the Nvidia driver versions I have now are:
    NVIDIA GeForce 9400M G: (currently the latest one from NVIDIA for Win8.1 x64)
    NVIDIA GeForce G210M: (currently the latest one from DELL for Win7 x64)

    Nvidia control center: 7.5.750.0

    And as for the Wifi / Bluetooth driver my Device Manager shows:
    Dell Wireless 1515 Wireless-N Adapter: (23/10/2009) by Atheros Communications Inc.
    Dell Wireless 370 Bluetooth Mini-card: (30/09/2013) by Broadcom Corporation

      My System SpecsSystem Spec

  2. #22

    Posts : 8
    Windows 8.1 x64 and Ubuntu 13.10 x32


    Just upgraded the Nvidia driver from the manufacturer site. I only have the 9400M.

    Confirming that my Bluetooth and Wifi 1515 drivers appear as:

    Dell Wireless 1515 Wireless-N Adapter: (23/10/2009) by Atheros Communications Inc.
    Dell Wireless 370 Bluetooth Mini-card: (30/09/2013) by Broadcom Corporation.

    The 210 Hybrid may be a factor in the other problems you describe but that I cannot test. I wonder if the extra Video card can be taken out for troubleshooting. If you don't do gaming and the 9400 works perfectly fine for regular computing and browsing.

      My System SpecsSystem Spec

  3. #23

    Posts : 8
    Windows 8.1 x64 and Ubuntu 13.10 x32


    I got the BSOD today during startup with a Kerneldata_Inparse_Error and the only change I made was the Nvidia Dirver install. I am reverting back to the Nvidia 9400M driver that Microsoft provided dated 9/30/2013.

    Try that or stay away from the latest nvidia Driver if you reinstall.

      My System SpecsSystem Spec

  4. #24

    Posts : 33
    Win 8.1 Pro x64

    Hi Orlando,

    Thanks for the update! I did not get this kind of error at the start up (yet). I might go for a fresh install at some point to make sure my drivers are not messed up in any way. I will surely make a backup of my current installation, just in case.

    Not having any issues with the latest Nvidia drivers so far. Might be caused by mixture of all drivers..

    Still hoping DELL would release Win 8.1 drivers for the Wifi card. There are Win 8.1 drivers from Atheros (the card manufacturer) but it seems the INF file does not contain the exact HW ID.
      My System SpecsSystem Spec

  5. #25

    U.K. - Suffolk
    Posts : 3
    Windows 8.1 64bit pro

    Thanks to everyone who has taken the time and made the effort to share their expertise with others. I struggled for 3 days on and off to update my 1340 to Windows 8.1. Then I found this forum and got 8.1 up and running in no time.
    My early attempts resulted in an error message: DRIVER_IRQL_NOT_LESS_OR_EQUAL, and then, after a reboot, an error message 0xc1900101 – 0x30018.
    The machine was supplied in 2009 with Windows 7. Last Christmas I updated to Win 8x64Pro and struggled for most of the holidays to get it running reliably. Ever since, although the machine was stable, I tolerated a few niggles. For example occasionally, after logging in, I had a fixed mouse pointer in the centre of the screen which persisted until the next shut down. A second pointer was also present that I could control – so I put up with the fault. Also, sometimes after shutting a window, I had to move the mouse pointer over the whole screen to refresh it in ‘chunks’.
    Since my successful 8.1 upgrade it has felt solid and faster than before, with not a single glitch.
    Broadly speaking, I followed the 6 step method described by Jim Lewis. Before starting, I downloaded the Dell 380 pkg, because I noticed that in step 3 - when the package was required - the wireless would be turned off.
    After step 6 I still had no BT , but I reran 380 pkg. Subsequent to that I got a dialogue offering to ‘repair’ and this did the trick.
    Then I followed the instructions relating to the video card drivers, and that’s working better than ever too. For example there is an option in my Sony Movie Studio Platinum 12 software to 'enable GPU acceleration of video processing'. Until now, this was greyed out, but now I can select “NVIDIA Geforce G210M” and editing is much slicker.
    I also agree with Jim’s analysis of Dell’s cosy relationship with MS. On day 2 of my original efforts to go to 8.1 I had a long service call to MS. They took control of my machine and pronounced that the issues were with drivers and to contact Dell – they even supplied a phone number. Dell were much less helpful. They had me cold start the 1340 with Fn held down, which ran protracted tests. One test presented an info window to say that there was a record of a fatal HDD error. I did indeed have a HDD crash in June, but the bootable diagnostic and repair CD downloadable from Seagate solved the problem. I had a long discussion with Dell about this and they reluctantly agreed to continue looking at my 8.1 install problems. After a total on-the-phone time of nearly 50 minutes they said that my machine could not run 8.1. That no drivers were available nor will be made available. I mentioned that there were instructions available on this forum, and evidence that people were running 8.1 - but of course, to no avail.

    So thanks guys - I wouldn't have known where to start - and indeed I'm left wondering how you guys crack these problems!
      My System SpecsSystem Spec

  6. #26

    Posts : 1
    Windows 8.1 Pro

    Hi to all and HAPPY NEW YEAR !!!
    Just installed Win 8.1 Pro x86.
    Since by default in BIOS all wireless communications are ENABLED I didn't make any changes.
    Did a little googlin about the file Network Application C71DK_WN_12.0_A02.EXE and found it here:
    all I did, was to run it and my BT works fine.
    Hope it'd work for you also.
      My System SpecsSystem Spec

  7. #27

    Posts : 1
    Windows 8.1


    I've been reading this forum and I really want to seek help.

    I tried using Orlando's steps but even the 1515 driver from Dell is not installing due to compatibility issues. The driver currently installed is 1510.

      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
How to get BT working on Win8.1 + Dell XPS 1340?

Similar Threads
Thread Forum
USB ports and SD card reader not working on Dell laptop
My SD card reader and USB ports have stopped working on my Dell Studio laptop running W8.1. They still identify what's put into the ports and reader as the USB sticks light up and the computer goes bing when an SD card is put in, but they don't show up in Windows Explorer. If I put a cabled USB...
Drivers & Hardware
Wake on Lan not working - Dell Inspiron 530
Hi, I have a Dell Inspiron 530 and I cannot get WOL to work. I have installed a new TP-LINK TG-3468 Network Card, which supports WOL. Remote Wake Up is enabled in the BIOS, as are the usual required settings on the Network Card properties. However whenever I hibernate, sleep, or shutdown...
Network & Sharing
Windows 8.1 RTM installation fails on Dell XPS 1340
Hi folks, I decided to install Win 8.1 RTM x64 yesterday but what I expected to be a breeze turned into a nightmare. Installation fails, I am even unable to get into Safe Mode. I was running Win 7 Ultimate x64 before without any issues whatsoever. I already described my issues here, with...
Installation & Setup
WebCam not working for Dell Latitude.
Hi. I have a Dell E5530 using windows 8.1 Been using laptop for 5+ months. For the first time today, I clicked the Camera panel and received msg “Connect a Camera”. Ran Dell PC diagnostics, no errors were found. I do not have a Imaging Device folder (that stores the Webcam) in Device...
Drivers & Hardware
Upgrade from Win7 Home Premium SP1 to Win8 Pro? [DELL N5110]
Is it possible to upgrade the laptop DELL N5110 from Win7 Home Premium SP1 64Bit to Win8 Pro 64Bit? Currently installed on Win7 Home Premium SP1 64Bit, is recommended to perform an upgrade or a clean installation? If I decide to upgrade, will all the files and folders saves? The system...
Installation & Setup
Dell BluetoothTravel Mouse stopped working
Any thoughts. My Dell Travel Mouse has been working fine until last weekend when it stopped responding. First, I thought it was the batteries, but it simply would not work on my Dell XPS M1300 laptop running Windows 8 Release Preview. I tried it on another laptop (running Windows 7) and it works...
Drivers & Hardware
Gestures not working in dell inspiron 1545
i came to know that laptops touchpad work as a touch screen in windows 8 and my dell inspiron 1545 is not supporting those can any one suggest me wat to do
Performance & Maintenance

Eight Forums Android App Eight Forums IOS App Follow us on Facebook