Windows 8 and 8.1 Forums

Driver install not being recognised RME Fireface800 S/card

  1. #1

    Driver install not being recognised RME Fireface800 S/card


    I upgrade to W8 from W7 last night (starting to regret the move but that's another pickle).

    My soundcard was working but intermittently I would get a noise which in W7 meant an application had crashed the soundcard, quite rare normally when 2 apps are using it on an ASIO driver in Cubase with a third party wrapped program.

    Firstlyt I unistalled the driver and switched off the unit then rebooted.
    I searched the C drive to remove any driver software as I several replicated some old and some new from previous updates.

    I now have the latest driver from RMEs website and by updating driver, as the driver has no install setup program, W8 is reporting the drivers unrecogonised. I now have no sound what so ever.

    I need help please. I have installed drivers manually for years and have a terrible feeeling this might be to do with driver signing which means I am out of my depth.

    Also any easy rollback methods I want to escape 8 I think for the time being

    Please help

    Thank you.


    RME User Forum / Windows 8 x64 FF800 issue

      My System SpecsSystem Spec

  2. #2

    I have a Sonar X2 recording studio. I've seen posts of upgrade problems with some devices on the Sonar forums. I have a Roland Octa-Capture and until Roland updated the drivers for Win 8 users were reporting problems using the Win 7 drivers.

    The gearslutz forum would be a better place to try and get help than this Win 8 forum if RME can't help.

    I will not be upgrading my DAW system to Win 8. I'm not convinced Win 8 is all that great yet. I have my test system upgraded but that is all for the time being.
      My System SpecsSystem Spec

Driver install not being recognised RME Fireface800 S/card

Similar Threads
Thread Forum
SD Card Not Being Recognised With Internal Card Reader
I have the very latest Windows 8.1 update. My internal multi card reader has been working fine for just under a year but just recently it has stopped recognising SD cards. When I insert a card it normally opens an explorer window but now it does nothing and does not show in file explorer. ...
Drivers & Hardware
Driver for tunner card?
Hai all, I have 'Philips SAA7130 TV Tuner/FM Radio/Video PCI Capture Card' .i want the win8 driver for this product... i have the winXP driver for this,but i didn't test it.. is any Win8 driver available for this or i want to test with XP's driver?
Drivers & Hardware
Need Driver for 15-in-1 memory card reader
I recently installed Windows 8.1 on my HP Pavilion p6130y desktop PC. Everything works great except Windows can't find and install the 15-in-1 memory card reader device. I know the device is connected to the mother board because the light in the card reader comes on when I insert a memory card,...
Drivers & Hardware
driver for memory card reader
i am using windows 8 i have a driver missing for my memory card reader RT55139/ i am using a lenovo laptop Ive tried updating my driver through updates but it says driver cant be found. does it matter if i don't update this driver and if it is important to be updated where can i find the updates...
Drivers & Hardware
graphics card driver problems
I recently upgraded to HP8300 elite i7 desktop pc running with windows8 64 bit. Unfortunatley, when i tried to install my previsou graphics card, Axle 9300GS 256MB GDDR2 Arctic Cooling S-Video, i couldnt make the system recognize the card nor did i manage to find an adequate driver. i would...
Graphic Cards
Not sure if my wireless card driver is updated or not
I upgraded to Windows 8 Pro and supposedly I installed all the Windows 8 drivers I got from my laptop's manufacture website (Sony) but when I go to device manager in control panel my wireless card has the yellow exclamation mark and in the properties it says that no driver update is installed even...
Drivers & Hardware
TV card usually not recognised until reboot
Hi all Got a Compro S350 satellite TV card and have Windows Media centre. I boot my PC, start media centre, go onto live TV and it tells me no TV signal/device is found. I simply reboot and it works fine. Not that hard to get around but annoying all the same. Any ideas?
Drivers & Hardware

Eight Forums Android App Eight Forums IOS App Follow us on Facebook