Windows 8 and 8.1 Forums

BSOD at startup due to ntoskml.exe ?

  1. #1

    Posts : 4
    win 8.1

    BSOD at startup due to ntoskml.exe ?

    Help needed from searching event logs and the web most stop errors I have gotten point to ntoskml.exe file as being the problem I have run Memory tests, HHD tests not sure if its a driver or hardware problem not sure to turn next any help would be appreciated.

    dm log attached

      My System SpecsSystem Spec

  2. #2

    Posts : 660
    windows 8.1

    Out of 19 memory dumps there were 7 different BSOD error codes. The differing error codes are usually symptomatic of a lower level problem within the system. They are usually caused by one of these things:
    - borked (broken) hardware (several different procedures used to isolate theproblem device)
    - BIOS issues (check for updates at the motherboard manufacturer's website)
    - overclocking/overheating - You'll know if you're overclocking or not. If uncertain we can suggest things to check.
    - compatibility issues (3rd party hardware/drivers)
    - low-level driver problems
    - or even malware (scanned for when we ask for hardware diagnostics from
    Initial Hardware Diagnostics or Hardware Diagnostics ).
    (Analyse based on canned speech of John carrona)

    Ten of your dumpfiles mentioned Memory corruption.
    Please test your memory with Memtest 86+.
    What brand of memory modules have you in your system?( My analyseprogram WinDBg did not named the modules). Check if they are compatible with your system.

    3 dumpfiles blames atikmpag.sys. this is the driver for your Graphic card ATI Radeon 3000 Graphics
    Please update to the latest driver, you need the legacy driver. info here Latest AMD Catalyst Graphics Driver for Windows 8

    It is known that many network devices with windows 7/8driver have problems with windows 8.1
    You have a
    Linksys AE1000 device with drivers from january 2010. Please update this to the latest windows 8.1 compatible drivers, also update your other wireless/ Bluetooth/Audio drivers etc.

    Your BIOS dates from october 2012. Please check at the manufacturer's website to see if there are any BIOS updates available for your system. Also check the readme file to see if they apply to the problems that you are having. Please be advised that flashing the BIOS is a very unforgiving process - and one mistake canphysically damage your motherboard.

    You can get ahead start on the hardware diagnostics if you'd like - they are located here: Hardware

    Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :
    Note: firstcheck the support/driver downloadsite of your OEM model or system for thelatest windows 8.1 drivers.

    ae1000w7 fffff801`a8243000 fffff801`a8358000 Fri Jan 15 09:15:48 2010 (4b502434) 00115f70 ae1000w7.sys

    Driver Description: Linksys AE1000 High-Performance Wireless-N Adapter
    Driver Update Site: AE1000 Support | High Performance Wireless-N Adapter

    atikmpag fffff801`a7200000 fffff801`a725f000 Mon Jun 18 22:41:29 2012 (4fdf9279) 0005dc7f atikmpag.sys
    atikmdag fffff801`a74a4000 fffff801`a8057000 Mon Jun 18 23:21:01 2012 (4fdf9bbd) 00b60a38 atikmdag.sys

    Driver Description: ATI Video driver
    Driver Update Site: Support & Drivers

    L1C63x64 fffff801`a8057000 fffff801`a8079000 Mon Apr 01 05:15:17 2013 (5158fbc5) 000245c4 L1C63x64.sys
    Driver Description: Qualcomm Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
    Driver Update Site: Drivers for Atheros AR8151 and Windows 7
    Last edited by lifetec; 08 May 2014 at 15:53.
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    win 8.1

    Hi lifetec Thinks for checking my bug files and your help and recommendations,no overclocking on my part, running with default settings,I ran memory test 3 passes>no errors,HHD test>no errors last night,haven't got to updating drivers,will try to tonight,checked MB site for Bios update the latest other then what I have now, is a beta one,will hold off on that until updating drivers and see if that sorts out my problems.

    I noticed when I had only 1 stick of memory in I didn't get bsod on startup for 2-3 times in a row switched to other stick same results, ran both sticks mem. one at a time in both slots with same results, to make sure it wasn't a bad slot on MB and again no bsod if that means anything significant, when I get home tonight I will try to do more testing and update my drivers. Thanks again
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    win 8.1

    Update Install latest wireless adapter driver, and in the device manager the Atheros Controller is listed as a AR8161(NDIS 6.30) not
    AR8151 so didn't update from link provided not sure if it could be and issue.

    As long as there is only 1 stick of memory in either slot at a time runs and starts with no errors, its only when I put sticks in both slots at the same time I get errors on startup.
    I've ran memory tests on both sticks individually in both slots with no memory errors, not sure if its a driver issue or a Bios setting issue... I'm stumped Thinks for any further help.
      My System SpecsSystem Spec

  5. #5

    Posts : 660
    windows 8.1

    Atheros has a generic driver.
    But this is the link to latest AR81861 driver Drivers for Atheros AR8161 and Windows 8. with version number Check your version number in device manager first.

    I tend it is more a bios issue.
    Are your memorymodules compatible with your mainboard.?
    Did you use the automatic setting set by your mainboard, sometimes the settings are not set correct for your module.
    And must you manually set the right settings(p.ex. I had some OCZ memory once with 7-7-7-1.8v and my mainboard always set it to 1.65v).
    Most brands have a userforum where you can ask specific issues with your memory and specific mainboards.
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    win 8.1

    Lifetec thanks for the help sorting this problem out, have updated drivers didn't make any difference.

    It seems to be a memory compatibly issue with memory not being a matched kit with MB, system runs great in single channel its only when I put both sticks of memory in dual channel that it puts out stop errors.

    Has run fine for 5 days now in single channel without any BSOD on startup.

    Thanks again
      My System SpecsSystem Spec

BSOD at startup due to ntoskml.exe ?

Similar Threads
Thread Forum
[BSOD] on Startup: IRQL_Not_Less_Or_Equal
Hello. Two days ago I installed a driver for my Rosewill network card. Here is where I got the driver ( as I am running Windows 8.1 64-bit Enterprise). Unfortunately, the driver is somehow incompatible. After installing it, I have been getting the...
BSOD Crashes and Debugging
Help. BSOD at startup
I get BSOD once in a while during startup with "Kernel Data Inpage Error". I did chkdsk /f /r and tried memory diagnostic. got a positive result also did a clean install of windows but still getting BSOD. I've attached the files. Please help me out.
BSOD Crashes and Debugging
BSOD right after startup, seems to be about IRQ?
Windows 8.1, I can reboot, login, and get to the desktop, but then about 2 or 3 minutes later it locks up and crashes with a DPC_WATCHDOG_ERROR. I am attaching the file from the (cool!) diagnostic tool in hopes someone can help! Frank
BSOD Crashes and Debugging
BSOD on startup
Hello again, Recently I thought I solved my BSOD problem, listed here. I thought it was Norton 360's fault. I uninstalled Norton and all of the sudden I am Blue Screening again on...
BSOD Crashes and Debugging
BSOD when I do shutdown and then startup (Fast Startup on)
Please see the attached logs. This is a fresh installation of Windows 8. System Specs is on my user profile.
BSOD Crashes and Debugging
BSOD on almost every startup of my new PC.
Hi ! I keep getting 1 BSOD on almoste every startup of my new PC. After the restart no more BSOD appears, until next start.... The casue is almost all the the time causewd by driver hal.dll and 1ce61... Any ideas? Greetings from Sweden
BSOD Crashes and Debugging
BSOD at startup
I turn on my computer, then the classic mainboard ad and some millisecond text come, and Windows 8 starts loading (that screen with the fish and a spinning thing). It spins for about 4-5 times then I get a BSOD (for reference, it usually takes 6 spins of the icon to load). I didn't install anything...
BSOD Crashes and Debugging

Eight Forums Android App Eight Forums IOS App Follow us on Facebook