Hello Again,

I have checked the iaStor.sys driver and the date is 4th June 2009 and version is, I tried to install the 2 drivers you suggested and I got the following error for both of them "this computer does not meet the minimum requirements for installing the software".

Is there an alterative or will I have to live with the out dated driver?