Windows 8 and 8.1 Forums

Most browsers doesn't load a site properly

  1. #1

    Most browsers doesn't load a site properly


    So lately I have trouble accessing full content page of a site which is CS:GO News -
    This is a CSGO related gaming site which contains news of e-sports for those who are wondering. Usually this takes no more than 30 seconds for the site to fully load and display its content. I've used Firefox, Google Chrome and Internet Explorer but it still displays nothing but the background image, advertisement banners and error page, as shown on the attachments. I refresh many times but it is still the same. My friends can access this site normally and I can too on my phone so the problem is on my laptop or browser or something. Any help is appreciated.
    Attached Thumbnails Attached Thumbnails 1.jpg   2.jpg   3.jpg  

      My System SpecsSystem Spec

  2. #2

    Posts : 49
    8 point zero and 10

    Unfortunately for 8.1 and previous systems,
    the code used online in websites varies with the wind and tends to be cutting edge which is not always compatible with ie10 / 11 and other browsers. Updates do not always keep up with new code.

    You might find that Edge in Windows 10 does well with the latest website code.

    This is what your link looks like in Edge using Windows 10.

    Click image for larger version
      My System SpecsSystem Spec

  3. #3

    I see. Guess I just have to browse the site on my phone. I'm still reluctant to upgrade to Windows 10. Thanks anyway
      My System SpecsSystem Spec

Most browsers doesn't load a site properly

Similar Threads
Thread Forum
Certain pages won't load in any browsers
Hi everyone, I spent an entire day browsing thru other topics with the same problem and I tried all the solutions that were listed, but to no avail - using win 8.1, certain sites just will not load in any browsers (tried Firefox, Opera, Chrome, IE) on my desktop pc. Usually they get stuck at...
Browsers & Mail
Browsers do not load pages properly!
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Browsers & Mail
My Internet browsers won't load anything
Hey guys. I am not able to load any pages using Firefox or Internet explorer. I have tried resetting my windsock and itp and it still won't work. I've also tried deleting any 3rd party firewalls I had but that didn't work either. I just got this laptop a week ago too so ya. Any help you can give me...
Browsers & Mail
Web browsers won't load pages after 8.1 upgrade
Kept ignoring prompts to upgrade to 8.1. Finally went ahead and did it and now neither IE or Chrome will load web pages. The programs themselves open but nothing happens. Not even a "can't load page" message. I am connected to the internet and I tried a few apps that seemed to work as normal. I've...
Browsers & Mail
Odd problem, webpages don't load properly a lot of times
I used to have this problem long time ago, it disappeared, but it came back again. Basically, whenever I load up a webpage, via chrome, internet explorer or anything, sometimes it would fail to go to the website entirely and give me an erorror that the website is not found without even checking...
Browsers & Mail
Computer connects to wifi but does not load browsers
I have a tiny wireless piece from realtek that my dad had bought. This piece was working fine up until recently. I had built my own tower and put the piece in there from our old one.. All has been working up until now. Now when I turn on my new tower the wifi connects but does not work. No...
Network & Sharing
My virtual box does not load properly .
Hello could someone help me or tell me why i am getting these errors? 7b217cb3ea86c25a73d9a7de11a34ea1.png

Eight Forums Android App Eight Forums IOS App Follow us on Facebook