Windows 8 and 8.1 Forums not loading with https, Firefox and IE

  1. #1

    Posts : 2
    Windows 8 not loading with https, Firefox and IE

    Hi guys and gals,

    New to this forum, so I hope it the right place for and way of explaining this problem.

    I just bought my first PC, which is pretty awesome after having worked on laptops for years.
    Here is the configuration:
    - i7 4790K
    - MSI Z97 Gaming 5
    - MSI GTX 980
    - Corsair Vengeance Pro Red 16GB 1600 MHz CL9
    - Corsair RM750
    - Samsung 850 Pro 256GB SSD

    This is also my first system with Windows 8.

    Now here is the problem:
    After installing my favorite browser Firefox, for some reason it won't load properly.
    It automatically tries to load the https version of google, which makes sense.
    But it gives my the "Untrusted connection error" (but then in Dutch, so I hope it is correctly translated).
    When I delete the "s" and try http it loads fine, but then my search results are different from my laptop with Windows 7 and only the categories "Web" and "Images" are shown.
    The same happens in Internet Explorer.

    I have tried the solutions as described on the Mozilla support pages, but without any luck.

    I hope someone on this forum can help me out.

    Thanks in advance and best regards,


      My System SpecsSystem Spec

  2. #2

    Posts : 2
    Windows 8

    Just found out that Internet Explorer has similar problem on my Windows 7 laptop.
    Google Search results only show the categories "Web" and "Image".

    Anyone that might have a solution?
      My System SpecsSystem Spec not loading with https, Firefox and IE

Similar Threads
Thread Forum
Can't browse some HTTPS sites, Facebook not loading CSS
I am running 8.1 64 bit on my Samsung ATIV Book 9 plus laptop and am having issues loading some HTTPS sites. Wierdly, Facebook is also not loading CSS at all. I have been trying to solve this on my own for a couple of weeks at least but I think it's gotten the better of me now. I am getting the...
Browsers & Mail
Google Chrome AND Mozilla Firefox freeze my whole PC.
Hello, I've been having problems with Google Chrome's freezes for quite a while now. They are random, first you see that your browser doesn't respond anymore, but then neither does the PC. You wait up to 3 minutes, and everything works out. But that's not really ideal. So, in order to see what...
Browsers & Mail
Some pages loading slowly in Firefox
My browser of choice is Firefox but I have the same problems in Chrome also. First a little background. I'm running Windows 8.1 for the last month (thanks to TECHNET) and up until 1 week ago I had Roadrunner light with download speeds around 9 to 10 Mbps. Last week I upgraded to higher speed...
Browsers & Mail

Eight Forums Android App Eight Forums IOS App Follow us on Facebook