Windows 8 and 8.1 Forums

My Internet browsers won't load anything

  1. #1

    My Internet browsers won't load anything

    Hey guys. I am not able to load any pages using Firefox or Internet explorer. I have tried resetting my windsock and itp and it still won't work. I've also tried deleting any 3rd party firewalls I had but that didn't work either. I just got this laptop a week ago too so ya. Any help you can give me I would really appreciate. Thanks

      My System SpecsSystem Spec

  2. #2

    Posts : 216
    Windows 8.1 Pro with Media Center

    Ok, need a bit more info. Are you able to load with any other browser?

    Are you wirelessly or physically connected. If you are physically connected to a router, check your IP address of your system and see if you have one assigned. It will usually be a 192.168.1.x. If it is anything else, your aren't connected. Check your cable.

    If it's wireless, have you gone through the connection steps to connect to your wireless router?

    Some system specs would help too.
      My System SpecsSystem Spec

  3. #3

    Posts : 115

    Hi and welcome to Eightforums,
    Along with the good advice so far,
    Please add which firewalls you added to the new machine also what third party security suite do you use and what was pre-installed,
      My System SpecsSystem Spec

My Internet browsers won't load anything

Similar Threads
Thread Forum
Internet Connection but browsers do not work.
Hello, I have just recently installed Windows 8 Pro and have had no problems, except my internet browsers. I am connected to the internet and can use some programs using it such as skype, but none of my browsers will work. (Internet explorer, Google chrome, Firefox.) In google chrome i get...
Network & Sharing
Connected to internet, but no browsers work (Windows 8.1)
Around a week ago I installed Windows 8.1, and I can't help but think this problem is related to that. My computer (a Toshiba Satellite C855) is apparently connected to the internet, but yesterday I suddenly couldn't browse any websites. I didn't change any settings before this happened. This...
Network & Sharing
Browsers do not load pages properly!
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Browsers & Mail
Web browsers won't load pages after 8.1 upgrade
Kept ignoring prompts to upgrade to 8.1. Finally went ahead and did it and now neither IE or Chrome will load web pages. The programs themselves open but nothing happens. Not even a "can't load page" message. I am connected to the internet and I tried a few apps that seemed to work as normal. I've...
Browsers & Mail
Internet Explorer does not open, but all other browsers do
Hello all, I don't really use internet explorer ( or as my dad calls it...internet exploder ahah ) a whole lot but bugs in general just irritate me sometimes. I have no idea when this started ( again, I don't use IE a lot ) I run a completely updated Windows 8.1 (home?) edition operating...
Browsers & Mail
Computer connects to wifi but does not load browsers
I have a tiny wireless piece from realtek that my dad had bought. This piece was working fine up until recently. I had built my own tower and put the piece in there from our old one.. All has been working up until now. Now when I turn on my new tower the wifi connects but does not work. No...
Network & Sharing
Internet Explorer 10 vs other browsers
Hello. Since I read many related topics about font rendering in IE10, I give my personal feeling. On my 1920*1080 DELL monitor, these are font rendering screenshots between IE10 and FF17. IE screenshot : 14051
Browsers & Mail

Eight Forums Android App Eight Forums IOS App Follow us on Facebook