Windows 8 and 8.1 Forums

Google Chrome Pages Do Not Load at All Windows 8.1

  1. #11

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center

    Quote Originally Posted by MAUIFC View Post
    Quote Originally Posted by David Bailey View Post
    Have you tried this:Attachment 39081
    Hi. I can't even get the menu to display like you have it. How do I get this menu to come up?Thanks.
    Click the tiny horizontal bars to the right of the star at the top right.

      My System SpecsSystem Spec

  2. #12

    Posts : 1
    Windows 7


    Have you tried solving it by changing google chrome compatibility mode as windows 8...I dont have windows 8 os but i wish it will help..

      My System SpecsSystem Spec

  3. #13

    Posts : 1
    Windows 8.1

    I have sort of the same problem, except NONE of my browsers load pages, although the computer is connected to the Internet, but Skype works and Frostwire DID but not anymore.

    os: Windows 8.1
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Google Chrome Pages Do Not Load at All Windows 8.1

Similar Threads
Thread Forum
Google Chrome on initial startup takes too long to load
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
Browsers & Mail
Browsers do not load pages properly!
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Browsers & Mail
Web browsers won't load pages after 8.1 upgrade
Kept ignoring prompts to upgrade to 8.1. Finally went ahead and did it and now neither IE or Chrome will load web pages. The programs themselves open but nothing happens. Not even a "can't load page" message. I am connected to the internet and I tried a few apps that seemed to work as normal. I've...
Browsers & Mail
No pages other than Google load
Hi all, apparently I have a pretty common problem but none of the solutions I have found seem to work. Here's the issue. Since upgrading to windows 8.1 I have been having issues with my internet connection. I can be browsing the web fine and then all of a I won't be able to load any pages...
Browsers & Mail
Unable to Load Pages While Downloading
I've got a new desktop which is connected to my house wifi using an USB adaptor. The signal quality is constantly at 5 bars but I find myself frequently having to refresh multiple times whenever I load a new page on the browser either because it's not loading or pictures or not showing. Pages...
Network & Sharing
Google Chrome takes a long time to load, IE is fine
Hi, not sure if I posted in the right section but just wanted to ask some help on how to fix Chrome as it is taking an unusually long time to load. It started just today a few hours ago when I logged into Facebook here in my laptop, I normally don't use it in my laptop as I just use it on my phone...
Browsers & Mail
Browser won't load Web Pages
Hi, I have a new Sony Vaio Duo 11 laptop. Up to a few days ago I could connect without any problem to the internet using IE. Suddenly every time I launch Internet Explorer It will not connect to any web page (This page can't be displayed) My connection is through WiFi and the connection is...
Browsers & Mail

Eight Forums Android App Eight Forums IOS App Follow us on Facebook