Windows 8 and 8.1 Forums

Google Chrome takes a long time to load, IE is fine

  1. #1

    Posts : 5
    Windows 8 Pro 64-bit

    Google Chrome takes a long time to load, IE is fine

    Hi, not sure if I posted in the right section but just wanted to ask some help on how to fix Chrome as it is taking an unusually long time to load. It started just today a few hours ago when I logged into Facebook here in my laptop, I normally don't use it in my laptop as I just use it on my phone mainly and have a desktop at school where I submit my school files early to avoid submitting them on my laptop. But when I was forced to submit at home and use Facebook on my laptop to submit my files, Chrome then starts taking a very long time to load, about 10-15 minutes. It isn't an internet problem as were getting a pretty average 7 mbps, and strange thing is IE is working well and fine. Tried doing some research and some suggested it was a firewall issue but I doubt it, as I never tweak my antivirus settings. I tried this When Google Chrome won't start up | Computerworld Blogs but couldn't continue as I seem to be missing the debug.log mentioned and so couldn't make sure if I was having the same problem, so pretty lost at the moment. Any help would be greatly appreciated.

    Edit : Oh and forgot to mention, after the 15 minute wait for chrome to open, and while I STILL have the browser open, opening new Chrome windows is then back to normal. But soon as I close my Chrome windows I then have to wait lots again. And it seems no matter how many shortcuts I try to open, I remember I clicked Chrome about 20 times it only always opens just 2 Chrome windows

      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    Just an observation that I don't see where you attempted an uninstall and reinstall. That would be my first course of corrective action.
      My System SpecsSystem Spec

  3. #3

    Posts : 315
    Windows 8.1 consumer 64 bit

    Try "Menu/Tools/Clear Browsing Data" and select at least cache, from the beginning of time. If that does not work try clearing everything. Perhaps some stored data is corrupted...
      My System SpecsSystem Spec

Google Chrome takes a long time to load, IE is fine

Similar Threads
Thread Forum
Takes a long time to connect to the Internet after waking
After waking the computer it immediately shows that it's connected to the Wifi network, but I can't access the Internet. Hovering the mouse over the network icon in the taskbar shows me the following (see attached). Happens on all networks I've tried. After a minute or so it starts to work, but...
Network & Sharing
LAN connection takes too long time
When I reboot Windows I get the login after approx 10 sec. But after I login it takes approx 25 sec for the network connection to get airborne --- first a red cross and then yellow triangle. Where is the bottleneck ? I have a fast Intel NIC and my LAN runs at 1 GBits and the Internet speed is...
Network & Sharing
Google Chrome on initial startup takes too long to load
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
Browsers & Mail
Suddenly boot up takes a very long time.
Upgraded to 8.1 last weekend. Thought I'd got most of the wrinkles sorted but now a couple more have emerged. Discovered compatibility issues with Nuance Paperport 14. Removed and re-installed but to no avail. But since then boot up takes an inordinately long time. In addition Firefox doesn't...
General Support
Computer seems to boot twice and takes a very long time
Hello everyone, The attached video will NOT win the Youtube film of the year award, however, I hope that someone might be able to help. My Dell XPS8700 is like a 16 year old, friendly one minute and totally nuts the next for no reason at all! The computer DOES boot, but there's no beep and...
General Support
Network drive connection takes long time - why?
Greetings. I have 2 PC's. Both are now running Windows 8. The main PC was running Windows 7 and I there mapped a network drive (z:) to the Win8 PC. It worked very nice. The second PC was also shown in "networks" in "my Computer" right after boot of Main PC. So network for sharing is set up...
Network & Sharing
Takes very long time to show up drives in My Computer
Hi, I'm using Windows 8 Pro N with 32-bit. I found some problem SOMETIME whenever I tried to open My Computer, it takes a very long time to show up my drives and removable disks. 21505 Here's the screenshot of it. The Green Bars is moving damn slow, For sometime only. Besides, I also...
Drivers & Hardware

Eight Forums Android App Eight Forums IOS App Follow us on Facebook